Ipiphany works best on the latest version of Chrome. 

Alternatively you can use one of the following alternative web browsers:

Support for older browser versions:

  • Ipiphany does not officially support out-of-date browser versions, however if your web browser version is still fairly recent then this will likely also work without issues. However we recommend you upgrade to the latest version for security and performance reasons.
  • Internet Explorer is not supported.
Did this answer your question?